02:55:54  * daurnimatorquit (Ping timeout: 260 seconds)
03:00:22  * daurnimatorjoined
03:01:36  * Namidairoquit (*.net *.split)
03:06:06  * Namidairojoined
05:37:03  * SkyRocknRolljoined
06:32:45  * SkyRocknRollquit (Ping timeout: 258 seconds)
06:52:12  * SkyRocknRolljoined
07:22:38  * rendarjoined
12:14:51  * rgrinbergjoined
13:27:49  * SkyRocknRollquit (Remote host closed the connection)
14:47:54  * APNGquit (Ping timeout: 276 seconds)
14:55:41  * dobsonquit (Quit: Leaving)
15:05:01  * dobsonjoined
15:40:25  * Sonijoined
15:41:50  * Sonichanged nick to APNG
15:43:16  * APNGquit (Remote host closed the connection)
15:43:32  * APNGjoined
16:14:59  * APNGquit (Changing host)
16:14:59  * APNGjoined
16:16:51  * Sonijoined
16:17:10  * Soniquit (Changing host)
16:17:10  * Sonijoined
16:17:35  * Soniquit (Remote host closed the connection)
16:17:50  * APNGquit (Quit: Leaving)
16:18:01  * Sonijoined
16:22:43  * Sonichanged nick to APNG
16:50:52  * creationixquit (Quit: ZNC - http://znc.in)
16:51:19  * creationixjoined
19:24:24  * rendarquit (Ping timeout: 258 seconds)
19:25:34  * dave24joined
19:31:29  <dave24>hello lads, I have two files: main.lua and db.lua, main.lua requires db.lua which requires "json". This throws an error saying module 'json' not found when run with `luvit main.lua`. It works when everything is in one file. What am I missing?
19:41:19  <SinisterRectus>sounds like you're doing something wrong
19:41:24  <SinisterRectus>is db requiring main by any chance
19:41:30  <dave24>nope
19:42:00  <dave24>running `luvit db.lua` also throws no errors
19:42:08  <SinisterRectus>are you using require('json')
19:42:50  <dave24>i used `require "json"`, should do the same thing
19:42:59  <SinisterRectus>yes
19:43:18  <SinisterRectus>idk. i'm able to require luvit modules from the non-main file
19:44:06  <dave24>have you got them installed somehow? have you got a package.lua that lists them as dependency or something like that?
19:46:00  <SinisterRectus>no, it's included in the standard luvit installation
19:54:19  * rendarjoined
19:59:11  <dave24>do you know where the package is supposed to be? in package.preload?
19:59:39  <dave24>*module
21:03:01  * dave24quit (Quit: leaving)
22:32:11  * rendarquit (Quit: std::lower_bound + std::less_equal *works* with a vector without duplicates!)